Alias for not is_empty.

Some people prefer to have conditions grammatically easier to read.

assert [1,2,3].not_empty  == true
assert [1..1[.not_empty   == false

Property definitions

core $ Collection :: not_empty
	# Alias for `not is_empty`.
	#
	# Some people prefer to have conditions grammatically easier to read.
	#
	#     assert [1,2,3].not_empty  == true
	#     assert [1..1[.not_empty   == false
	fun not_empty: Bool do return not self.is_empty
lib/core/collection/abstract_collection.nit:69,2--75,48