not is_empty
.Some people prefer to have conditions grammatically easier to read.
var map = new HashMap[String, Int]
assert map.not_empty == false
map["one"] = 1
assert map.not_empty == true
# Alias for `not is_empty`.
#
# Some people prefer to have conditions grammatically easier to read.
#
# var map = new HashMap[String, Int]
# assert map.not_empty == false
# map["one"] = 1
# assert map.not_empty == true
fun not_empty: Bool do return not self.is_empty
lib/core/collection/abstract_collection.nit:613,2--621,48